MyFRITZ!App Service - Knowledge Base

MyFRITZ!App Service

MyFRITZ!App displays the error message "An SSL error has occurred"

When you start MyFRITZ!App or attempt to establish a connection to the FRITZ!Box, MyFRITZ!App displays one of the following error messages:

  • "Error while reading the necessary data: An SSL error has occurred and a secure connection to the server cannot be made."
  • "An error occurred while connecting to FRITZ!Box [...]: An SSL error has occurred and a secure connection to the server cannot be made. [-1200]"

Simply proceed as described below. After each measure, check whether the issue persists.

1 Installing the latest FRITZ!OS

Due to changes made by Apple, communication between MyFRITZ!App and the FRITZ!Box is only possible with iOS 8.4.1 and later if FRITZ!OS 6.06 or later is installed on the FRITZ!Box:

2 Setting up MyFRITZ!App

If you are using a FRITZ!Box with FRITZ!OS 6.06 to 6.10, manually configure MyFRITZ!App:

  1. Start MyFRITZ!App.
  2. Tap the gear icon on the bottom right to open the "Settings" menu.
  3. Tap "+" in the "Settings" menu.
  4. Enter a name of your choice for the connection to the FRITZ!Box in the "Name" field.
  5. Enter the MyFRITZ! domain name of the FRITZ!Box (for example pi80ewgfi72d2os42.myfritz.net) in the "Address" field.

    Note:You can find the MyFRITZ! domain name in the user interface under "Internet > Permit Access > FRITZ!Box Services" in the "Web address of your FRITZ!Box" field. It begins after the "https://" and ends with "myfritz.net".

  6. Enter the name of a FRITZ!Box user who is authorized to access the FRITZ!Box from the Internet in the "User" field.

    Note:You can edit the access rights for FRITZ!Box users under "System > FRITZ!Box Users" or "System > FRITZ!Box Password" in the user interface.

  7. Enable the option "Save password" and tap "Save".
  8. Enter your MyFRITZ! password and confirm the message regarding the certificate used for the FRITZ!Box with "Continue".
  9. Enter the password for the FRITZ!Box user.

3 MyFRITZ!App can no longer be used

If FRITZ!OS 6.06 or later is not available for your FRITZ!Box model, then you can no longer use MyFRITZ!App. There will also be no further FRITZ!OS update available for FRITZ!Box models whose development has been discontinued that would allow the use of MyFRITZ!App in iOS 8.4.1 or later with them. We have already made updates available for current FRITZ!Box models.